Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Vodafone and Multiple Small Networks in Egypt
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to Vodafone and multiple small networks in Egypt. This incident has been resolved.
      Posted Jan 06, 2022 - 21:32 PST
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to Vodafone and multiple small networks in Egypt. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 06, 2022 - 19:32 PST
      Update
      We are continuing to work with our carrier partner to resolve SMS delivery delays to Vodafone and multiple small networks in Egypt. We expect to provide another update in 8 hours or as soon as more information becomes available.
      Posted Jan 06, 2022 - 12:15 PST
      Update
      We are continuing to work with our carrier partner to resolve SMS delivery delays to Vodafone and multiple small networks in Egypt. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Jan 06, 2022 - 08:18 PST
      Update
      We are continuing to work with our carrier partner to resolve SMS delivery delays to multiple networks in Egypt. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 06, 2022 - 06:15 PST
      Update
      We are experiencing SMS delivery delays when sending messages to a small subset of Egyptian Subscribers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 06, 2022 - 05:15 PST
      Investigating
      Our monitoring systems have detected a potential issue with SMS Delivery Delays towards Egypt. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jan 06, 2022 - 05:10 PST
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).