Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS delivery delays to US Operators
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Nov 29, 2019 - 18:01 PST
Monitoring
We are observing full recovery for US Short Code MMS delivery times and DLRs across all carriers. We'll continue to monitor and provide updates if there are any changes.
Posted Nov 29, 2019 - 11:56 PST
Identified
We're observing full recovery in delivery latency for MMS sent from US long codes. MMS sent from US Short codes are still experiencing delays. We'll continue working with our carrier partners to resolve this issue and we'll update this message as more information becomes available.
Posted Nov 29, 2019 - 11:15 PST
Investigating
We are observing delivery delays for MMS sent to US Operators. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information
Posted Nov 29, 2019 - 08:36 PST
This incident affected: CARRIER NETWORK (MMS Long Code, North America, MMS Short Code, North America).