Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Customers using Pay with Stripe payment provider experiencing issues
      Incident Report for Twilio
      Resolved
      The Stripe payment provider issue has been resolved and is operating normally at this time.
      Posted May 11, 2020 - 10:10 PDT
      Investigating
      Customers using Pay with Stripe payment provider are seeing high latencies or failures. Our Engineering team are working with Stripe on this issue.
      Posted May 11, 2020 - 10:03 PDT
      This incident affected: TWILIO PLATFORM (Other).