Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Messaging Service Degradation
Incident Report for Twilio
Resolved
The degradation of Messaging Services has been resolved. Degradation occurred between 08:00 and 09:03 PST and affected all messages going through a Messaging Service including SMS, MMS, and Whatsapp. Messages sent through a Messaging service during this time were delayed but not failed. All effected messages have been dequeued and sent, and the Messaging Services product is operating normally at this time. This incident is resolved.
Posted Jan 12, 2022 - 09:31 PST
Monitoring
Messaging Services are now operating normally. Degradation occurred between 08:00 and 09:03 PST and affected all messages going through a Messaging Service including SMS, MMS, and Whatsapp. Messages sent through a Messaging service during this time were delayed but not failed. All effected messages have been dequeued and sent at this time. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Jan 12, 2022 - 09:06 PST
Investigating
We are experiencing an ongoing degradation issue impacting Messaging Services. The first alert went off at 08:00 PST. Our engineering team is actively investigating and we will provide another update in 30 minutes or as soon as more information becomes available.
Posted Jan 12, 2022 - 08:52 PST
This incident affected: PROGRAMMABLE MESSAGING (MMS, SMS, Messaging Channels).