Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Failures on the Salt (Orange) network in Switzerland
Incident Report for Twilio
Resolved
We are no longer seeing delivery failures for SMS sending to the Salt (Orange) network in Switzerland. This incident has been resolved.
Posted Mar 19, 2020 - 23:32 PDT
Monitoring
We are observing successful delivery on the Salt (Orange) network in Switzerland. We will continue to monitor to ensure a full recovery.
Posted Mar 19, 2020 - 22:44 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Mar 19, 2020 - 22:03 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Mar 19, 2020 - 19:53 PDT
Investigating
We are experiencing delivery failures when sending SMS to the Salt (Orange) network in Switzerland. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Mar 19, 2020 - 18:56 PDT
This incident affected: CARRIER NETWORK (SMS, Europe).