Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to US Carriers from a Small Subset of Twilio Shortcodes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to US Carriers via Short Codes for a subset of customers.. This incident has been resolved.
      Posted Nov 19, 2021 - 17:24 PST
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to US Carriers via Short Codes for a subset of customers. During this incident customers may have experienced SMS delivery failures. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 19, 2021 - 15:24 PST
      Update
      We are still experiencing SMS delivery delays to US Carriers from a small subset of Twilio Shortcodes. We are working with our carrier partners to resolve this issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Nov 19, 2021 - 11:24 PST
      Update
      We are still experiencing SMS delivery delays to US Carriers from a small subset of Twilio Shortcodes. We are working with our carrier partners to resolve this issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 19, 2021 - 09:28 PST
      Investigating
      We are experiencing SMS delivery delays to US Carriers from a small subset of Twilio Shortcodes. We are working with our carrier partners to resolve this issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Nov 19, 2021 - 08:32 PST
      This incident affected: CARRIER NETWORK (SMS Short Code, North America).