Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays on US Short Codes
      Incident Report for Twilio
      Resolved
      We have confirmed that the issue is now resolved. We are now observing immediate and stable delivery for inbound SMS from all networks to Twilio short codes. All services are operating normally at this time.
      Posted Jan 22, 2019 - 07:21 PST
      Update
      Our carrier partner has successfully implemented a fix. Inbound SMS from AT&T and Sprint handsets to Twilio US short codes are now being processed. There is still a queue on the carrier partner’s platform, so customers may still experience latency until this queue is processed. We will provide an update once the queue clears.
      Posted Jan 22, 2019 - 06:31 PST
      Identified
      We are observing recovery for inbound SMS sent from Verizon, T-Mobile and MetroPCS devices. Inbound SMS sent from AT&T and Sprint devices to a subset of Twilio short codes however, are still experiencing delays. Outbound SMS sent from short codes and long code SMS are not affected. Our carrier partner has identified the issue and is working on a fix. We will provide an update as soon as available.
      Posted Jan 22, 2019 - 03:36 PST
      Investigating
      We’re observing further delays for inbound SMS sent from AT&T, T-Mobile and Sprint devices to a subset of Twilio short codes. SMS sent from Verizon devices and outbound SMS are not affected. We are working with our carrier partner to resolve the issue.
      Posted Jan 22, 2019 - 01:27 PST
      Monitoring
      We are observing recovery in short code SMS latency for outbound and inbound messages sent from and to US short codes. We will continue to monitor and work with our carrier partners to confirm the issue is fully resolved.
      Posted Jan 22, 2019 - 00:30 PST
      Investigating
      We are observing increased delays in SMS delivery for inbound and outbound SMS sent from/to a subset of US short codes. Our engineers are working with our carrier partner to resolve the issue and will provide more information as soon as available.
      Posted Jan 22, 2019 - 00:15 PST
      This incident affected: CARRIER NETWORK (SMS Short Code, North America).