Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Repeated SMS delivery to Verizon numbers
      Incident Report for Twilio
      Resolved
      All services are operating normally.
      Posted Mar 15, 2018 - 20:57 PDT
      Monitoring
      We have not observed further instances of repeated SMS delivery for Verizon numbers. Our engineering team is continuing to monitor the services. We will provide another update when we have confirmation from our carrier partner that the issue has been resolved.
      Posted Mar 15, 2018 - 19:33 PDT
      Update
      We are continuing to investigate this issue with our carrier partners. We will provide another update in 2 hour.
      Posted Mar 15, 2018 - 17:47 PDT
      Investigating
      We are investigating a few observed instances of repeated SMS delivery to Verizon numbers. We have engaged our carrier partner to investigate this issue. We will provide another update in 1 hour.
      Posted Mar 15, 2018 - 16:47 PDT
      This incident affected: PROGRAMMABLE MESSAGING (SMS).