Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays in Responses from Twilio Console and Usage API
Incident Report for Twilio
Resolved
We are no longer experiencing delays in responses from the Twilio Console and the Usage API. The incident is now resolved. The service is operating normally at this time.
Posted Jul 21, 2021 - 13:06 PDT
Monitoring
Responses from the Twilio console and the usage API are now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 21, 2021 - 11:06 PDT
Update
We are experiencing delays in responses from the Twilio Console and the usage API. Our engineers are working to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 21, 2021 - 10:46 PDT
Investigating
Our monitoring systems have detected a potential issue with delays in console responses. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 21, 2021 - 10:32 PDT
This incident affected: DEVELOPER TOOLS (Console, REST API).