Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Failures to US Verizon Network
Incident Report for Twilio
Resolved
We no longer observe long code MMS delivery failures to Verizon. MMS delivery is operating normally at this time.
Posted Sep 02, 2020 - 13:46 PDT
Monitoring
Our carrier partner has made changes to resolve the issue causing long code MMS delivery failures to Verizon. We have removed long code MMS traffic from Picture SMS for Verizon. Messages should now appear as MMS messages. We will continue to monitor the situation for the next 30 minutes before we mark the incident as fully resolved.
Posted Sep 02, 2020 - 13:11 PDT
Identified
We have identified the issue causing long code MMS delivery failures to Verizon. We are working with our carrier partner to restore service. To mitigate impact on long code MMS deliverability we continue to route long code MMS traffic to Picture SMS for Verizon. Messages will appear as an SMS with a link to access the image. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 02, 2020 - 12:59 PDT
Update
We continue to investigate an issue causing long code MMS delivery failures to the US Verizon network. Our engineers are working with our carrier partner to resolve the issue. To ensure that long code MMS deliverability is not impacted to Verizon network, we are rerouting long code MMS traffic to Picture SMS to the Verizon network. Messages will appear as an SMS with a link to access the image. We expect to provide another update in 1 hr or as soon as more information becomes available.
Posted Sep 02, 2020 - 11:48 PDT
Update
Our engineers continue to actively investigate an issue causing MMS delivery failures to US Verizon network. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hr or as soon as more information becomes available.
Posted Sep 02, 2020 - 11:18 PDT
Update
We are currently investigating an issue causing MMS delivery failures to US Verizon network. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Sep 02, 2020 - 10:49 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 02, 2020 - 09:19 PDT
This incident affected: CARRIER NETWORK (MMS Long Code, North America).