Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to MCI Network In Iran
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to MCI Network In Iran. This incident has been resolved.
      Posted Aug 13, 2022 - 07:23 PDT
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to MCI Network In Iran. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 13, 2022 - 05:17 PDT
      Update
      We are continuing to experience SMS delivery delays when sending messages to MCI Network In Iran. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Aug 13, 2022 - 02:11 PDT
      Update
      We are continuing to experience SMS delivery delays when sending messages to MCI Network In Iran. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Aug 12, 2022 - 22:11 PDT
      Update
      We are continuing to experience SMS delivery delays when sending messages to MCI Network In Iran. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 12, 2022 - 20:11 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to MCI Network In Iran. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Aug 12, 2022 - 19:11 PDT
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).