Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Issue with Multiple Products Due to Degradation in our US East Data Center
      Incident Report for Twilio
      Resolved
      Issue with multiple products due to degradation in our US East data center has been resolved and all affected services are operating normally at this time. Please contact our Customer Support if you need a copy of the incident report.
      Posted Dec 07, 2021 - 21:39 PST
      Update
      We are seeing recovery of the underlying issue that caused some degradation in the US-EAST-1 Region, causing service degradation with multiple products. We are seeing improvement across most products.
      We are moving this incident to "monitoring" and will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available. We expect to monitor this for several hours to assure continued recovery.
      Posted Dec 07, 2021 - 19:38 PST
      Update
      We are seeing recovery of the underlying issue that caused some degradation in the US-EAST-1 Region, causing service degradation with multiple products. We are seeing improvement across most products. We are still seeing degradation with the following products: Twilio Live - recovering but still showing degradation in TimedMetadata Requests.
      We are moving this incident to "monitoring" and will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available. We expect to monitor this for several hours to assure continued recovery.
      Posted Dec 07, 2021 - 19:18 PST
      Update
      We are seeing recovery of the underlying issue that caused some degradation in the US-EAST-1 Region, causing service degradation with multiple products. We are seeing improvement across most products. We are still seeing degradation with the following products: WhatsApp - new registrations are still degraded. Twilio Live - recovering but still showing degradation in TimedMetadata Requests.
      We are moving this incident to "monitoring" and will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available. We expect to monitor this for several hours to assure continued recovery.
      Posted Dec 07, 2021 - 17:18 PST
      Update
      We are seeing recovery of the underlying issue that caused some degradation in the US-EAST-1 Region, causing service degradation with multiple products. We are seeing improvement across most products. We are still seeing degradation with the following products: Flex Insights- Log in issues are recovered, but data from the impacted time will not be available for several hours. WhatsApp - new registrations are still degraded. Twilio Live - still showing degradation in TimedMetadata Requests. Billing API - showing delayed publishing of usage data.
      We are now seeing recovery in Serverless, Assets and Functions.
      We are moving this incident to "monitoring" and will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available. We expect to monitor this for several hours to assure continued recovery.
      Posted Dec 07, 2021 - 15:48 PST
      Monitoring
      We are seeing recovery of the underlying issue that caused some degradation in the US-EAST-1 Region, causing service degradation with multiple products. We are seeing improvement across most products. We are still seeing degradation with the following products: Flex Insights- Log in issues are recovered, but data from the impacted time will not be available for several hours. WhatsApp - new registrations are still degraded. Twilio Live - still showing degradation in TimedMetadata Requests. Severless - still showing degradation in Asset invocations and Build creations. Billing API - showing delayed publishing of usage data.
      We are moving this incident to "monitoring" and will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available. We expect to monitor this for several hours to assure continued recovery.
      Posted Dec 07, 2021 - 15:39 PST
      Update
      We are seeing recovery of the underlying issue that caused some degradation in the US-EAST-1 Region, causing service degradation with multiple products. We are seeing improvement across most products. We are still seeing degradation with the following products: Flex Insights- Log in issues are recovered, but data from the impacted time will not be available for several hours. WhatsApp - new registrations are still degraded. Twilio Live - still showing degradation in TimedMetadata Requests. Severless - still showing degradation in Asset invocations and Build creations. Billing API - showing delayed publishing of usage data.
      We are moving this incident to "monitoring" and will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available. We expect to monitor this for several hours to assure continued recovery.
      Posted Dec 07, 2021 - 15:38 PST
      Update
      We have identified the cause of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Flex Platform, Authy ApI, Whatsapp - new registrations only, Notify, Functions/Assets builds unable to be created, Conversations, Programmable Chat, Video Recording, Video Compositions, Event Streams. Twilio Live, Programmable FAX, Studio, Twilio Verify V1 is down, Twilio Verify V2 is operational. We are now seeing lower MPS for SMS and MMS A2P traffic. On further investigation we have determined that Auto Pilot, Super Sim and voice are not affected by this outage as reported earlier. The billing API is now seeing recovery. Console is seeing recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Dec 07, 2021 - 14:36 PST
      Update
      We have identified the cause of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Flex Platform, Authy ApI, Whatsapp - new registrations only, Notify, Functions/Assets builds unable to be created, Conversations, Programmable Chat, Video Recording, Video Compositions, Event Streams. Twilio Live, Twilio Verify V1 is down, Twilio Verify V2 is operational. We are now seeing lower MPS for SMS and MMS A2P traffic. On further investigation we have determined that Auto Pilot, Super Sim and voice are not affected by this outage as reported earlier. The billing API is now seeing recovery. Console is seeing recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Dec 07, 2021 - 13:51 PST
      Update
      We have identified the cause of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Flex Platform, Authy ApI, Whatsapp - new registrations only, Notify, Functions/Assets builds unable to be created, Conversations, Programmable Chat, Video Recording, Video Compositions, Event Streams.
      Twilio Live, Twilio Verify V1 is down, Twilio Verify V2 is operational. On further investigation we have determined that Auto Pilot, Super Sim and voice are not affected by this outage as reported earlier. The billing API is now seeing recovery. Console is seeing recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Dec 07, 2021 - 13:20 PST
      Update
      We have identified the cause of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Flex Platform, Authy ApI, Whatsapp - new registrations only, Notify, Functions/Assets builds unable to be created, Conversations, Programmable Chat, Video Recording, Video Compositions, Event Streams, Super Sim.
      Twilio Live, Twilio Verify V1 is down, Twilio Verify V2 is operational. On further investigation we have determined that Auto Pilot and voice is not affected by this outage as reported earlier. The billing API is now seeing recovery. Console is seeing recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Dec 07, 2021 - 12:58 PST
      Update
      We have identified the cause of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Flex Platform, Authy ApI, Whatsapp - new registrations only, Notify, Functions/Assets builds unable to be created, Conversations, Programmable Chat, Video Recording, Video Compositions, Event Streams, Super Sim.
      Twilio Live, Twilio Verify V1 is down, Twilio Verify V2 is operational. On further investigation we have determined that Auto Pilot and voice is not affected by this outage as reported earlier. The billing API is now seeing recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Dec 07, 2021 - 12:32 PST
      Update
      We have identified the cause of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Flex Platform, Authy ApI, Whatsapp - new registrations only, Notify, Functions/Assets builds unable to be created, Conversations, Programmable Chat, Video Recording, Video Compositions, Event Streams, Super Sim.
      Twilio Live, Twilio Verify V1 is down, Twilio Verify V2 is operational. On further investigation we have determined that Auto Pilot and voice is not affected by this outage as reported earlier. The billing API is now seeing recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Dec 07, 2021 - 12:21 PST
      Update
      We have identified the cause of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Flex Platform, Authy ApI, Whatsapp new registrations, Notify, Functions/Assets builds unable to be created, Conversations, Programmable Chat, Video Recording, Video Compositions, Billing API, Event Streams, Super Sim.
      Twilio Live, Twilio Verify V1 is down, Twilio Verify V2 is operational. On further investigation we have determined that Auto Pilot is not affected by this outage. We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Dec 07, 2021 - 11:59 PST
      Update
      We have identified the cause of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Authy ApI, Conversations, Functions/Assets builds unable to be created, Programmable Chat, Video Recording, Video Compositions, Billing API, Event Streams
      Twilio Live, Twilio Verify V1 is down, Twilio Verify V2 is operational. On further investigation we have found that Programmable Voice was
      not affected. We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Dec 07, 2021 - 11:35 PST
      Update
      We have identified the cause of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Programable Voice, Authy ApI, Conversations, Functions/Assets builds unable to be created, Programmable Chat, Video Recording, Video Compositions, Billing API, Event Streams
      Twilio Live, Twilio Verify V1 is down, Twilio Verify V2 is operational. We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Dec 07, 2021 - 11:17 PST
      Update
      We have identified the cause of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Programable Voice, Authy ApI, Conversations, Functions/Assets builds unable to be created, Programmable Chat, Video Recording, Video Compositions, Billing API, Event Streams
      Twilio Live, We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Dec 07, 2021 - 11:07 PST
      Update
      We have identified the cause of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Programable Voice, Authy ApI, Conversations, Functions/Assets builds unable to be created, Programmable Chat, Video Recording, Video Compositions, Billing API, Event Streams
      Twilio Live, We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Dec 07, 2021 - 10:35 PST
      Update
      We have identified the cause of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Programable Voice, Authy ApI, Conversations, Functions/ Assets builds unable to be created, Programmable Chat, Video Recording, Video Compositions, Billing API, Event Streams
      Twilio Live, We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Dec 07, 2021 - 10:08 PST
      Update
      We have identified the cause of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Programable Voice, Authy ApI, Conversations, Functions/ Assets builds unable to be created, Programmable Chat, Video Recording, Video Compositions, Billing API, Event Streams.
      Twilio Live, We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Dec 07, 2021 - 09:40 PST
      Update
      We have identified the cause of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Programable Voice, Authy ApI, Conversations, Functions/ Assets builds unable to be created, Programmable Chat, Video Recording, Video Compositions, Billing API, Event Streams
      Twilio Live, We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Dec 07, 2021 - 09:39 PST
      Update
      We have identified the cause of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Programable Voice, Authy ApI, Conversations, Functions/ Assets builds unable to be created, Programmable Chat, Video Recording, Video Compositions, Billing API,
      Twilio Live, We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Dec 07, 2021 - 09:28 PST
      Update
      We have identified the cause of of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Programable Voice, Authy ApI, Conversations, Functions/ Assets builds unable to be created, Programmable Chat,
      Twilio Live, We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Dec 07, 2021 - 09:09 PST
      Identified
      We have identified the cause of of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. Affected products we have identified at this time: Flex Insights, Programable Voice, Authy ApI, Conversations, Functions/ Assets builds unable to be created, Programmable Chat,
      Twilio Live, We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Dec 07, 2021 - 08:48 PST
      Update
      We have identified the cause of of the issue in our US East data center causing a service interruption with multiple products and are working on mitigation. We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Dec 07, 2021 - 08:31 PST
      Update
      We are investigating a service interruption with multiple products due to degradation in our US East data center. We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Dec 07, 2021 - 08:17 PST
      Investigating
      We've become aware of a potential issue with our Serverless product. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Dec 07, 2021 - 07:57 PST
      This incident affected: FLEX (TaskRouter, Flex Application Platform, Flex Insights), DEVELOPER TOOLS (Console, Event Streams), ACCOUNT SECURITY (Authy 2FA, Verify, Authy App), SERVERLESS (Studio, Functions, Assets), PROGRAMMABLE VIDEO (Recordings, Compositions), TWILIO PLATFORM (Billing), PROGRAMMABLE VOICE (Conference), PHONE NUMBERS, PROGRAMMABLE CHAT, and PROGRAMMABLE MESSAGING (SMS, Messaging Channels, Conversations).