Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delays in Call Logs and Intermittent Errors when Deleting Calls
      Incident Report for Twilio
      Resolved
      The call logs that were affected by the incident have been backfilled. This incident of delays in calls showing up in call logs and intermittent errors when deleting calls from call logs has been resolved and call logs are being processed normally at this time.
      Posted Jun 16, 2022 - 19:52 PDT
      Update
      We are still working to backfill the historical data for call logs that were affected by the incident. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 16, 2022 - 18:01 PDT
      Update
      We are no longer seeing delays for new call logs via Console, API, and Voice Insights. We are currently working to backfill the logs that were affected by the incident. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 16, 2022 - 16:11 PDT
      Monitoring
      We are observing recovery with delays in call logs via Console, API, and Voice Insights. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 16, 2022 - 15:17 PDT
      Update
      We are continuing to investigate delays in calls showing up in call logs and intermittent errors when deleting calls from call logs. We found that this is affecting logs via Console, API, and Voice Insights. These delays will impact real time billing. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 16, 2022 - 14:59 PDT
      Update
      We are investigating delays in calls showing up in call logs and intermittent errors when deleting calls from call logs. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jun 16, 2022 - 13:46 PDT
      Investigating
      Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jun 16, 2022 - 13:26 PDT
      This incident affected: DEVELOPER TOOLS (Console, REST API) and PROGRAMMABLE VOICE (Voice Insights).