Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Errors with credit card payments
Incident Report for Twilio
Resolved
All systems are operating normally.
Posted 3 months ago. Oct 31, 2018 - 04:01 PDT
Monitoring
We are seeing recovery in credit card processing.
Posted 3 months ago. Oct 31, 2018 - 03:44 PDT
Investigating
We are currently investigating an increased level of errors in credit card payments. We are working with our payment provider to resolve the issue.
Posted 3 months ago. Oct 31, 2018 - 03:24 PDT
This incident affected: TWILIO PLATFORM (Console).