Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Errors creating new accounts on Twilio Impact Access Program
      Incident Report for Twilio
      Resolved
      A fix has been implemented and the issue has been resolved.
      Posted Mar 18, 2020 - 07:12 PDT
      Update
      We are continuing to investigate this issue. We will provide an update as soon as we have additional information.
      Posted Mar 18, 2020 - 05:30 PDT
      Update
      We are continuing to investigate this issue. We will provide an update as soon as we have additional information.
      Posted Mar 17, 2020 - 23:45 PDT
      Update
      We are continuing to investigate this issue. We will provide an update as soon as we have additional information.
      Posted Mar 17, 2020 - 19:43 PDT
      Investigating
      We are currently investigating this issue.
      Posted Mar 17, 2020 - 14:08 PDT
      This incident affected: TWILIO PLATFORM (Billing).