Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound Caller ID Issue to Singapore Numbers
Incident Report for Twilio
Resolved
The Singapore Twilio numbers are passing correct Caller IDs to Singapore destinations. All services are operating normally.
Posted Jul 27, 2020 - 02:11 PDT
Update
The Singapore Twilio numbers are passing correct Caller IDs to Singapore destinations. All services are operating normally.
Posted Jul 27, 2020 - 02:10 PDT
Investigating
We are observing a potential issue where outbound calls from Twilio Singapore numbers present incorrect Caller IDs to Singapore destinations. We are working with our carrier partner to confirm and resolve this issue.
Posted Jul 27, 2020 - 01:29 PDT
This incident affected: CARRIER NETWORK (Voice, APAC).