Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS delivery status callbacks issues to US handsets over Longcode
Incident Report for Twilio
Resolved
The issue of MMS delivery status callbacks when sending MMS from Twilio longcodes towards US handsets has been resolved. SMS Delivery Notifications & Status Callbacks is operating normally.
Posted 6 days ago. Aug 12, 2019 - 11:19 PDT
Update
We are still observing message status events degradation for some MMS sent to US handsets. We continue working with our carrier partners to restore the service. We will provide an update once we have confirmed the resolution.
Posted 7 days ago. Aug 12, 2019 - 06:41 PDT
Investigating
We have detected delays in receiving message status events for some MMS sent from US longcodes to US handsets. There is no impact to actual message delivery. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted 7 days ago. Aug 11, 2019 - 22:36 PDT
This incident affected: CARRIER NETWORK (MMS Long Code, North America).