Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays in Account Recovery and Phone Change Authy Emails
Incident Report for Twilio
Resolved
We are no longer seeing delays in email delivery for phone change and account recovery requests. We will continue to monitor the service closely and apologize for the interruption in service
Posted 8 months ago. May 25, 2018 - 18:31 PDT
Investigating
We are currently experiencing delays in email delivery for phone change and account recovery requests for the Authy product
Posted 8 months ago. May 25, 2018 - 18:10 PDT
This incident affected: AUTHY (Authy 2FA).