Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Media Fetches from Api.twilio.com Resources Failing for a Subset of Customers
Incident Report for Twilio
Resolved
The issue causing media fetch failures has been resolved and the service is operating normally at this time.
Posted Mar 25, 2021 - 17:48 PDT
Update
We continue to monitor for system stability. Media fetches from api.twilio.com continue to operate normally. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 25, 2021 - 16:01 PDT
Update
We continue to monitor for system stability. Media fetches from api.twilio.com continue to operate normally. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 25, 2021 - 14:04 PDT
Update
We continue to monitor for system stability. Media fetches from api.twilio.com continue to operate normally. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 25, 2021 - 12:09 PDT
Monitoring
We have addressed the issue regarding media fetches from api.twilio.com resources for Programmable Messaging and Programmable Voice. These resources are now operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Mar 25, 2021 - 11:40 PDT
Update
We continue to investigate elevated media fetch failures from api.twilio.com for Twilio's Rest API, impacting Programmable Voice and Programmable Messaging. Customers who are hosting their call recordings or messaging media on api.twilio.com may encounter call or message failures. Our engineering team is actively working on the issue, and we will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 25, 2021 - 10:51 PDT
Update
We are continuing to investigate this issue.
Posted Mar 25, 2021 - 10:28 PDT
Update
We are continuing to investigate this issue.
Posted Mar 25, 2021 - 10:27 PDT
Update
We are currently investigating elevated media fetch failures from api.twilio.com for Twilio's Rest API, impacting the following Twilio services: Programmable Voice and Programmable Messaging. Our engineering team is actively working on the issue, and we will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 25, 2021 - 10:22 PDT
Investigating
We've become aware of a potential issue with media fetches from api.twilio.com resources. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Mar 25, 2021 - 09:56 PDT
This incident affected: PROGRAMMABLE VOICE (Recording, TwiML) and PROGRAMMABLE MESSAGING (MMS).