Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      502 Errors on Twilio REST API Requests
      Incident Report for Twilio
      Resolved
      Twilio REST API 502 errors for a subset of requests has been resolved and Twilio REST API is operating normally at this time.
      Posted May 25, 2022 - 12:57 PDT
      Update
      Twilio REST API is continuing to operate normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
      Posted May 25, 2022 - 12:19 PDT
      Monitoring
      Twilio REST API is now operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
      Posted May 25, 2022 - 11:50 PDT
      Update
      We are currently investigating reports of 502 errors for a subset of requests to the Twilio REST API. Our engineering team is actively working on the issue, and we will provide another update in 1 hour or as soon as more information becomes available.
      Posted May 25, 2022 - 11:07 PDT
      Investigating
      Our monitoring systems have detected a potential issue with the Twilio API returning 502 responses. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted May 25, 2022 - 10:38 PDT
      This incident affected: DEVELOPER TOOLS (REST API).