Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Customers Redirected When Accessing Support
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Jan 15, 2020 - 06:11 PST
Investigating
We are currently experiencing an issue in which some customers are being redirected when trying to access https://support.twilio.com/hc/en-us/requests. Customers should still be able to contact Support by emailing help@twilio.com directly, or via console at https://www.twilio.com/console/support
Posted Jan 15, 2020 - 04:53 PST
This incident affected: TWILIO PLATFORM (Customer Support Center).