Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Short Code Delivery Issues to Rogers and Fido Solutions Canada
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 20 days ago. Jun 29, 2019 - 21:37 PDT
Update
We are continuing to investigate this issue.
Posted 20 days ago. Jun 29, 2019 - 17:32 PDT
Investigating
We are experiencing short code SMS delivery issues to Rogers and Fido Solutions Canada. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted 20 days ago. Jun 29, 2019 - 17:31 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America) and PROGRAMMABLE MESSAGING (SMS).