Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Yemen
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Sep 12, 2020 - 10:38 PDT
Update
We are no longer experiencing delivery delays for Yemen. This incident has been resolved.
Posted Sep 12, 2020 - 10:37 PDT
Update
We are experiencing SMS delivery delays when sending SMS messages to Yemen Mobile in Yemen. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in one hour.
Posted Sep 12, 2020 - 10:23 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 12, 2020 - 10:13 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa) and PROGRAMMABLE MESSAGING (SMS).