We are no longer experiencing SMS delivery delays when sending messages to Tigo Network in Guatemala. This incident has been resolved.
Posted Nov 18, 2022 - 03:58 PST
Monitoring
We are observing recovery in SMS delivery delays when sending messages to Tigo Network in Guatemala. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 18, 2022 - 02:12 PST
Update
We are still experiencing SMS delivery delays when sending messages to Tigo Network in Guatemala. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Nov 18, 2022 - 01:25 PST
Update
We are still observing SMS delivery delays when sending messages to the Tigo Network in Guatemala. Our engineers continue to work with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 17, 2022 - 23:31 PST
Investigating
We've become aware of a potential issue with SMS Delivery Delays to Guatemala. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Nov 17, 2022 - 22:31 PST
This incident affected: PROGRAMMABLE MESSAGING (SMS).