Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Flex - Delays Accepting Inbound and Initiating Outbound for a Subset of Calls
Incident Report for Twilio
Resolved
We are no longer experiencing issues with delayed call queue times in Flex. This incident has been resolved.
Posted Dec 01, 2021 - 11:49 PST
Update
We are no longer experiencing issues with delayed call queue times in Flex. This incident has been resolved.
Posted Dec 01, 2021 - 11:14 PST
Update
Delayed call queue times in Flex were causing Delays accepting inbound and initiating outbound for a subset of calls. Flex is now operating normally. We will continue to monitor for system stability for the next 24 hours. We’ll provide another update in 24 hours or as soon as more information becomes available.
Posted Nov 30, 2021 - 15:46 PST
Monitoring
Call queue times in Flex are now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 30, 2021 - 13:29 PST
Update
We are investigating elevated call queue times for a subset of Flex customers. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 30, 2021 - 12:45 PST
Investigating
We are investigating elevated call queue times for a subset of Flex customers. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Nov 30, 2021 - 12:22 PST
This incident affected: FLEX (Flex Application Platform).