Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Issues to Movinet Venezuela
      Incident Report for Twilio
      Resolved
      We have confirmed the recovery of issues related to SMS delivery to Movilnet Venezuela. Service has been restored.
      Posted Apr 11, 2019 - 20:13 PDT
      Investigating
      We are experiencing SMS delivery issues to Movilnet Venezuela. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Apr 11, 2019 - 18:42 PDT
      This incident affected: CARRIER NETWORK (SMS, Latin America).