A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2020 - 05:17 PDT
Update
Our engineers are continuing to work towards a fix for this issue
Posted Apr 21, 2020 - 04:03 PDT
Update
Our engineering team is still in the process of working towards a fix for this issue. We will update as soon as we have more information.
Posted Apr 20, 2020 - 23:57 PDT
Identified
Our engineers have identified the issue and are working on a fix. We will provide another update as soon as additional information is available.
Posted Apr 20, 2020 - 19:57 PDT
Update
We are seeing delays in processing usage and billing events for Programmable Wireless SIMs. Our on-call engineers are investigating.
Posted Apr 20, 2020 - 18:31 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.