Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Long Code SMS Delivery Delays to and from Networks in the United States and Canada
Incident Report for Twilio
Resolved
We are no longer experiencing long code SMS delivery delays to and from networks in the United States and Canada. This incident has been resolved.
Posted Jan 12, 2020 - 09:33 PST
Monitoring
We are observing recovery in delivery, but users may experience some minor delays. We will continue to monitor and provide an update as soon as additional information is available
Posted Jan 11, 2020 - 22:33 PST
Update
We continue to work with our carrier partner to resolve the issue. We will provide an update as soon as additional information is available.
Posted Jan 11, 2020 - 21:09 PST
Update
We are observing long code SMS delivery delays to and from networks in the United States and Canada. Both incoming and outgoing messages are affected. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jan 11, 2020 - 17:23 PST
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jan 11, 2020 - 17:11 PST
This incident affected: CARRIER NETWORK (SMS Long Code, North America).