Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Failures to Asia Cell Iraq
Incident Report for Twilio
Resolved
We are no longer experiencing delivery failures to Asia Cell Iraq,. This incident has been resolved.
Posted Aug 01, 2020 - 05:42 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 01, 2020 - 03:32 PDT
Monitoring
We are observing successful SMS delivery to Asia Cell Iraq. We will continue to monitor to ensure a full recovery.
Posted Aug 01, 2020 - 02:10 PDT
Update
We are experiencing delivery failures sending SMS to Asia Cell. Our engineers are working with our carrier partner to resolve the issue. We will provide an update within 1 hour.
Posted Aug 01, 2020 - 01:08 PDT
Investigating
Our monitoring systems have detected a potential issue with Programmable SMS. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Aug 01, 2020 - 00:50 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).