Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
A portion of Twilio inbound phone numbers in Singapore are not receiving calls
Incident Report for Twilio
Resolved
The incident that was causing a portion of Twilio inbound phone numbers in Singapore to not receive calls has been resolved.
Posted May 11, 2020 - 21:53 PDT
Update
Our engineers are still investigating the issue that is causing a portion of Twilio inbound phone numbers in Singapore to not receive calls. We will provide more information as soon as we have updates.
Posted May 11, 2020 - 20:39 PDT
Update
Some customers are unable to reach their Twilio Singapore phone numbers. We are investigating the issue with carriers in the region and will provide updates as they are available.
Posted May 11, 2020 - 19:46 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted May 11, 2020 - 19:40 PDT
This incident affected: CARRIER NETWORK (Voice, APAC).