Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays and Failures to US Cellular and Google Voice numbers for a small subset of traffic
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery failures to US Cellular and Google Voice numbers in the US. This incident has been resolved.
Posted Oct 17, 2020 - 16:53 PDT
Monitoring
We are observing successful SMS delivery to US Cellular and Google Voice numbers in the US for the past 30 minutes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 17, 2020 - 16:26 PDT
Update
We are experiencing delivery delays and failures sending to US Cellular and Google Voice numbers in the US. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 17, 2020 - 15:40 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Oct 17, 2020 - 15:30 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America).