Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delays with processing account balance changes for some customers
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Apr 03, 2020 - 11:41 PDT
      Update
      We are continuing to investigate this issue that appears to result in delayed processing of account balance changes.
      Posted Apr 03, 2020 - 11:12 PDT
      Update
      For some customers, we are observing issues regarding account balance changes such as payments that are failing to process in a timely manner, causing some customers to remain with negative account balances after completing payments. Other impacts include account balances potentially running down before recharge payments are processed. Our engineers are working to resolve the issue. We will provide an update as soon as we have more information.
      Posted Apr 03, 2020 - 10:13 PDT
      Investigating
      Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Apr 03, 2020 - 09:50 PDT
      This incident affected: DEVELOPER TOOLS (Console) and TWILIO PLATFORM (Billing).