Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      On Call Engineers Are Investigating an Issue Twilio Console for account closure
      Incident Report for Twilio
      Resolved
      Erroneous SID being added to the email reply has been resolved and Twilio Console in Self-service account closure is operating normally at this time.
      Posted Jan 31, 2024 - 16:43 PST
      Monitoring
      Twilio Console in Self-service account closure is now operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
      Posted Jan 31, 2024 - 16:08 PST
      Update
      Our engineers have identified the issue of erroneous SID being added to the email reply upon self-service request for account closure when using Twilio console and are working to deploy a fix. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 31, 2024 - 15:52 PST
      Investigating
      Our monitoring systems have detected a potential issue Twilio console for account closure. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jan 31, 2024 - 15:26 PST
      This incident affected: DEVELOPER TOOLS (Console).