Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Receipt (DLR) Latency to Toll-Free Numbers in the United States
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 7 months ago. Jul 21, 2018 - 17:02 PDT
Monitoring
SMS delivery receipts (DLRs) are arriving without delay. All services are fully operational.
Posted 7 months ago. Jul 21, 2018 - 16:39 PDT
Update
We continue to experience SMS delivery receipt (DLR) latency to toll-free numbers in the United States. Message delivery remains unaffected and messages are arriving without delay. Our engineers continue to work with our carrier partner to restore service. We will provide an update within 2 hours
Posted 7 months ago. Jul 21, 2018 - 16:20 PDT
Investigating
We are currently experiencing SMS delivery receipt (DLR) latency to toll-free numbers in the United States. Message delivery is not impacted and messages are arriving without delay. Our engineers are working with our carrier partner to restore service. We will provide an update within 60 minutes.
Posted 7 months ago. Jul 21, 2018 - 15:20 PDT
This incident affected: PROGRAMMABLE MESSAGING (SMS).