Status
Welcome to the Twilio status page. Here you will find real-time information about status of our services.
Degraded Service for receiving calls in Mexico
Incident Report for Twilio
Resolved
All services are now operating normally.
Posted about 1 month ago. Feb 08, 2017 - 19:40 PDT
Investigating
We are currently investigating an outage with some of our phone numbers in Mexico being unreachable. We are working with our carrier partner to identify the problem and find a resolution.
Posted about 1 month ago. Feb 08, 2017 - 17:38 PDT
This incident affected: Programmable Voice (PSTN).