Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Inconsistencies with Suppressions - Block Lists

        Incident Report for Twilio

        Monitoring

        We are continuing to monitor the issue causing inconsistencies with Suppression - Blocks list data (v3/suppression/blocks). Mail delivery is fully operational. We will provide the next update tomorrow morning PDT or sooner if details change.
        Posted Aug 31, 2026 - 21:27 PDT

        Update

        Our engineers are continuing to investigate the issue causing inconsistencies with Suppression - Blocks list data (v3/suppression/blocks). Mail send remains unaffected. We will provide another update in an hour or as soon as more information becomes available.
        Posted Aug 31, 2026 - 20:41 PDT

        Update

        Our engineers are continuing to investigate the issue causing inconsistencies with Suppression - Blocks list data (v3/suppression/blocks). Mail send remains unaffected. We will provide another update in an hour or as soon as more information becomes available.
        Posted Aug 31, 2026 - 19:45 PDT

        Update

        Our engineers are continuing to investigate the issue causing inconsistencies with Suppression - Blocks list data (v3/suppression/blocks). Mail send remains unaffected. We will provide another update in an hour or as soon as more information becomes available.
        Posted Aug 31, 2026 - 18:43 PDT

        Update

        Our engineers are continuing to investigate the issue causing inconsistencies with Suppression - Blocks list data (v3/suppression/blocks). Mail send remains unaffected. We will provide another update in an hour or as soon as more information becomes available.
        Posted Aug 31, 2026 - 17:33 PDT

        Update

        Our engineers are continuing to investigate the issue causing inconsistencies with Suppression - Blocks list data (v3/suppression/blocks). Mail send remains unaffected. We will provide another update in an hour or as soon as more information becomes available.
        Posted Aug 31, 2026 - 16:32 PDT

        Update

        Our engineers are continuing to investigate the issue causing inconsistencies with Suppression - Blocks list data (v3/suppression/blocks). Mail send remains unaffected. We will provide another update in an hour or as soon as more information becomes available.
        Posted Aug 31, 2026 - 15:33 PDT

        Update

        Our engineers are continuing to investigate the issue causing inconsistencies with Suppression - Blocks list data (v3/suppression/blocks). Mail send remains unaffected. We will provide another update in an hour or as soon as more information becomes available.
        Posted Aug 31, 2026 - 14:36 PDT

        Update

        Our engineers are continuing to investigate the issue causing inconsistencies with Suppression - Blocks list data (v3/suppression/blocks). Mail send remains unaffected. We will provide another update in an hour or as soon as more information becomes available.
        Posted Aug 31, 2026 - 13:42 PDT

        Investigating

        Starting around 11:45 AM PDT, our engineers began investigating an issue where users may experience inconsistencies while viewing Suppression - Blocks list data via API (v3/suppression/blocks) and the dashboard. Mail send is not impacted. We will provide another update in an hour or as soon as more information becomes available.
        Posted Aug 31, 2026 - 12:45 PDT
        This incident affects: SendGrid API and SendGrid Website.