Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound SMS Failures to a Subset of Twilio Singapore Phone Numbers
Incident Report for Twilio
Resolved
We are no longer experiencing inbound SMS delivery failures to Twilio Singapore Phone Numbers. This incident has been resolved.
Posted Sep 09, 2021 - 09:26 PDT
Monitoring
We are observing recovery in inbound SMS delivery to Twilio Singapore numbers. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 09, 2021 - 07:26 PDT
Update
We are continuing to work with our carrier partner to resolve the issue of inbound SMS delivery failures to a subset of Twilio Singapore numbers. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 09, 2021 - 06:15 PDT
Investigating
We are experiencing inbound SMS delivery failures to a subset of Twilio Singapore numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 60 minutes or as soon as more information becomes available.
Posted Sep 09, 2021 - 05:15 PDT
This incident affected: CARRIER NETWORK (SMS, APAC).