Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Call Quality Issues to a Subset of Twilio Numbers From and To a number of European countries
      Incident Report for Twilio
      Resolved
      Call quality issues to a subset of Twilio numbers from and to a number of European countries have been resolved and is operating normally at this time.
      Posted Jul 01, 2024 - 07:18 PDT
      Monitoring
      We have started seeing recovery for Call quality issues to a subset of Twilio numbers from and to a number of European countries. We will continue to monitor to ensure a full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jul 01, 2024 - 05:08 PDT
      Update
      We continue to investigate Call Quality Issues to a Subset of Twilio Numbers from and to a number of European countries. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jul 01, 2024 - 03:39 PDT
      Investigating
      We are investigating Inbound Call Quality Issues to a Subset of Twilio Numbers from a number of European countries We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jul 01, 2024 - 02:37 PDT
      This incident affected: PROGRAMMABLE VOICE (Voice Insights).