Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Failures on Yemen Mobile
Incident Report for Twilio
Resolved
We are no longer experiencing delivery failures to Yemen Mobile. This incident has been resolved.
Posted Oct 15, 2020 - 20:11 PDT
Monitoring
We are observing successful SMS delivery to Yemen Mobile. We will continue to monitor to ensure full service recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 15, 2020 - 19:34 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Oct 15, 2020 - 19:01 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).