Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays on a subset of short codes to Bluegrass Wireless, Cellcom, Northeast Colorado Cellular and GCI Communication Corp in the USA
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery delays for a subset of short codes to Bluegrass Wireless, Cellcom, Northeast Colorado Cellular and GCI Communication Corp in the USA. This incident has been resolved.
Posted Feb 15, 2021 - 14:46 PST
Update
We continue to experience SMS delivery delays for a subset of short codes to Bluegrass Wireless, Cellcom, Northeast Colorado Cellular and GCI Communication Corp in the USA. This impacts inbound and outbound SMS. Our engineers are working with our carrier partners to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Feb 15, 2021 - 12:09 PST
Update
We continue to experience SMS delivery delays for a subset of short codes to Bluegrass Wireless, Cellcom, Northeast Colorado Cellular and GCI Communication Corp in the USA. Our engineers are working with our carrier partners to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 15, 2021 - 10:54 PST
Update
We are experiencing SMS delivery delays for a subset of short codes to Bluegrass Wireless, Cellcom, Northeast Colorado Cellular and GCI Communication Corp in the USA. Our engineers are working with our carrier partners to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 15, 2021 - 09:56 PST
Investigating
Our monitoring systems have detected a potential issue with SMS delivery delays. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Feb 15, 2021 - 09:42 PST
This incident affected: CARRIER NETWORK (SMS Short Code, North America).