Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delays in SMS delivery to and from Mexico handsets
      Incident Report for Twilio
      Resolved
      All services are operating normally.
      Posted Sep 18, 2017 - 13:30 PDT
      Monitoring
      Our carrier partner has resolved the issue. We are continuing to monitor the service.
      Posted Sep 18, 2017 - 13:22 PDT
      Update
      Our engineering team is investigating an issue with delivery delays of inbound and outbound sms messages to a subset of Twilio phone numbers in Mexico. We will provide another update in 1 hour.
      Posted Sep 18, 2017 - 12:41 PDT
      Investigating
      Our engineering team is investigating an issue with delivery delays of inbound and outbound sms messages to a subset of Twilio phone numbers in Mexico.
      Posted Sep 18, 2017 - 12:32 PDT
      This incident affected: PROGRAMMABLE MESSAGING (SMS).