Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Receiving calls in Netherlands
      Incident Report for Twilio
      Resolved
      Our carrier partner has informed us that the incident has been resolved and we have observed recovery.
      Posted Jul 08, 2019 - 10:37 PDT
      Investigating
      We have detected an issue when receiving calls for a subset of Twilio numbers in Netherlands. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Jul 08, 2019 - 06:58 PDT
      This incident affected: CARRIER NETWORK (Voice, Europe).