Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Inbound Call Failures to a Subset of Twilio Ireland Mobile Phone Numbers
      Incident Report for Twilio
      Resolved
      We are still working with our carrier partner to resolve the inbound call failures issue to a subset of Twilio Ireland mobile phone numbers. We will contact the impacted customers individually to address any concerns. If customers face any inbound call failures related to this incident, please contact support for further assistance.
      Posted Jun 15, 2022 - 11:03 PDT
      Update
      We are continuing to investigate inbound call failures to a subset of Twilio Ireland mobile phone numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Jun 14, 2022 - 19:16 PDT
      Update
      We are continuing to investigate inbound call failures to a subset of Twilio Ireland mobile phone numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Jun 13, 2022 - 19:16 PDT
      Update
      We are continuing to investigate inbound call failures to a subset of Twilio Ireland mobile phone numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Jun 12, 2022 - 19:16 PDT
      Update
      We are still investigating inbound call failures to a subset of Twilio Ireland mobile phone numbers. We continue to work with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as we have more information.
      Posted Jun 12, 2022 - 07:16 PDT
      Update
      We are still investigating inbound call failures to a subset of Twilio Ireland mobile phone numbers. We continue to work with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as we have more information.
      Posted Jun 11, 2022 - 09:16 PDT
      Update
      We are continuing to investigate inbound call failures to a subset of Twilio Ireland mobile phone numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Jun 10, 2022 - 09:28 PDT
      Update
      We are continuing to investigate inbound call failures to a subset of Twilio Ireland mobile phone numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Jun 09, 2022 - 09:26 PDT
      Update
      We are continuing to investigate inbound call failures to a subset of Twilio Ireland mobile phone numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted Jun 08, 2022 - 09:36 PDT
      Update
      We are continuing to investigate inbound call failures to a subset of Twilio Ireland mobile phone numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
      Posted Jun 07, 2022 - 17:45 PDT
      Update
      We are continuing to investigate inbound call failures to a subset of Twilio Ireland mobile phone numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
      Posted Jun 07, 2022 - 09:45 PDT
      Update
      We are continuing to investigate inbound call failures to a subset of Twilio Ireland mobile phone numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Jun 07, 2022 - 05:49 PDT
      Update
      We are continuing to investigate inbound call failures to a subset of Twilio Ireland mobile phone numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 07, 2022 - 03:51 PDT
      Investigating
      We are observing inbound call failures to a subset of Twilio Ireland mobile phone numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jun 07, 2022 - 02:46 PDT
      This incident affected: CARRIER NETWORK (Voice, Europe).