Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Failures to MCI Network, Iran
      Incident Report for Twilio
      Resolved
      We are now observing full and stable recovery for SMS sent to the MCI network in Iran. This issue is now resolved.
      Posted Mar 25, 2019 - 03:28 PDT
      Investigating
      We have detected an increase in delivery failures for SMS sent to the MCI mobile network in Iran. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
      Posted Mar 25, 2019 - 02:01 PDT