We have resolved an issue affecting the Twilio Console when accessing the Products & Services > Numbers & Senders > Port and Host > Port-in US Local page.
Posted Jul 08, 2026 - 08:32 PDT
Monitoring
We have resolved an issue affecting the Twilio Console when accessing the Products & Services > Numbers & Senders > Port and Host > Port-in US Local page. We'll monitor for 30 minutes.
Posted Jul 08, 2026 - 07:35 PDT
Identified
We have identified the root cause of the issue when accessing Products & Services, we'll provide an update as soon as we have more insights.
Posted Jul 08, 2026 - 06:19 PDT
Investigating
We are aware of an issue affecting the Twilio Console when accessing the Products & Services > Numbers & Senders > Port and Host > Port-in US Local page. Our team is actively investigating the root cause. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 08, 2026 - 05:13 PDT
This incident affected: DEVELOPER TOOLS (Console).