Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound delivery failures to Israel
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Dec 01, 2019 - 22:27 PST
Monitoring
We are observing signs of recovery with message delivery to Orange Israel. We continue to work with our carrier partner to restore service. We will provide further updates as soon as they are available.
Posted Dec 01, 2019 - 20:59 PST
Investigating
We are observing delivery failures for Outbound SMS to Israel via Orange. Our engineering team is working with our carrier partners to resolve the issue. We'll provide additional information as it becomes available.
Posted Dec 01, 2019 - 10:07 PST
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).