Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Flex Insights Historical Reporting Data not Refreshing
      Incident Report for Twilio
      Resolved
      We are no longer experiencing an issue with Flex Insights Historical Reporting Data not refreshing. This incident has been resolved.
      Posted Dec 07, 2022 - 04:35 PST
      Identified
      We have identified an issue with Flex Insights historical reporting data not refreshing with our vendor, and are actively working with them to resolve it. We will update in 4 hours, or as soon as we have more information.
      Posted Dec 07, 2022 - 00:49 PST
      Update
      We are continuing to investigate an issue with Flex Insights Historical Reporting Data not refreshing with our vendor. We will update in 2 hours or as soon as we have more information.
      Posted Dec 06, 2022 - 22:51 PST
      Update
      Our engineers have identified an issue with Flex Insights Historical Reporting Data not refreshing. Our engineering team has been alerted and is actively investigating with our vendor. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Dec 06, 2022 - 21:51 PST
      Investigating
      Our monitoring systems have detected a potential issue with Flex Insight. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Dec 06, 2022 - 21:43 PST
      This incident affected: FLEX (Flex Insights).