Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Three Ireland
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery delays when sending messages to the Three network in Ireland. This incident has been resolved.
Posted Mar 12, 2020 - 19:43 PDT
Update
We are continuing to investigate this issue with our carrier partners. We will provide an update as soon as additional information is available.
Posted Mar 12, 2020 - 18:56 PDT
Investigating
After seeing some initial recovery, we are again seeing delivery delays to Three Ireland. We will continue to investigate with our carrier partners and provide an update as soon as additional information is available.
Posted Mar 12, 2020 - 17:54 PDT
Monitoring
We are observing successful delivery to Three Ireland. We will continue to monitor to ensure a full recovery.
Posted Mar 12, 2020 - 13:05 PDT
Update
We are starting to see some recovery, but still experiencing delays. We will continue to provide updates as additional information is available.
Posted Mar 12, 2020 - 12:48 PDT
Update
We continue to investigate this issue with our carrier partners. We will provide an update as soon as additional information is available.
Posted Mar 12, 2020 - 10:10 PDT
Investigating
We are experiencing SMS delivery delays when sending messages to the Three network in Ireland Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Mar 12, 2020 - 08:45 PDT
This incident affected: CARRIER NETWORK (SMS, Europe).