Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delays to and from US toll free numbers
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery delays. This has been resolved.
Posted Jan 23, 2020 - 09:48 PST
Investigating
We are experiencing delivery delays for sending and receiving SMS from toll free numbers in the US. We are working with our carrier partner to resolve this issue and will provide further updates as they become available.
Posted Jan 23, 2020 - 09:24 PST
This incident affected: CARRIER NETWORK (SMS Toll-Free, North America).