Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Authy - Low SMS delivery rate
      Incident Report for Twilio
      Resolved
      Our Engineers have updated our SMS routing and we're seeing messages being delivered
      Posted Jun 13, 2017 - 10:23 PDT
      Investigating
      We're currently experiencing an issue with our provider and are working to correct the issue with SMS delivery to all supported world regions except Indonesia and Argentina.
      Posted Jun 13, 2017 - 10:03 PDT
      This incident affected: ACCOUNT SECURITY (Authy 2FA).